Створення бази даних в MS Excel 2010 використовуючи функцію «ГПР»

Про матеріал
В матеріалах Ви знайдете саму інструкційну картку для покрокового виконання завдання та приклади виконаного завдання
Перегляд файлу
Перегляд файлу тимчасово недоступний.
Перегляд файлу
Перегляд файлу тимчасово недоступний.
Перегляд файлу

 

Інструкційно-технологічна карта

Створення бази даних в MS Excel 2010 використовуючи «ГПР»

Назва

Опис технологічного процесу

Малюнок

Склад технологічних операцій.

  1. Завантажити табличний процесор MS Excel 2010.
  2. Встановити пароль для відкривання файлу (1111).
  3. Зберегти книгу у власній папці «Учень» під назвою «База БД ГПР».
  4. Завантажити ТБ MS Excel 2010.

  1. Перейменуйте Лист1 на база даних ГРП, створіть таблицю використовуючи автозаповнення я показано на зразку.
  2. В комірку В введіть наступну формулу:=СУММ(($L$1:$U$1=A2)*1), після введення формули натисніть комбінацію CTRL+SHIFT+Enter – це дасть можливість закінчити формулу і у Вас відразу в формулі котру Ви надрукували добавляться квадратні дужки як показано на зразку. (Пояснення по даній комбінації Ви знайдете у кінці роботи в текстовому варіанті) цей самий масив потрібно застосовувати для повного завершення формули на комірках В, D, F i W.
  3. В комірку D введіть наступну формулу: =СУММ(($L$2:$U$2=C2)*1).
  4. В комірку F введіть наступну формулу:=СУММ(($L$3:$U$3=E2)*1).
  5. В комірку Н введіть наступну формулу: =B2*D2*F2.
  6. На верхній рядок котрий у вас підписаний у вигляді літер від А до Н задайте режим фільтру.
  7. Після завершення обрахунку Ви отримаєте таблицю із такими значеннями як показано на зразку.
  8. В комірку W1 введіть наступний текст «Масив потрібних значень» і задайте параметр на панелі форматування «По центру».
  9.    В комірку W2 введіть наступну формулу: =(ЕЧИСЛО(ГПР(A2:A15;L1:U1;1;0))*1)*

(ЕЧИСЛО(ГПР(C2:C15;L2:U2;1;0)*1)

*(ЕЧИСЛО(ГПР(E2:E15;L3:U3;1;0))*1))

*G2:G15 і за допомогою автозаповнення протягніть формулу до комірки W15 і ви

 отримаєте такий вигляд формули і запису як на зразку зображення.

  1. В комірку V17 введіть текст «ГРП» а в комірку V18 «ПОИСКПОЗ».
  2.    Введіть в комірку W17 наступну формулу: =СУММ((ЕЧИСЛО(ГПР(A2:A15;L1:U1;1;0))*1)

*(ЕЧИСЛО(ГПР(C2:C15;L2:U2;1;0)*1)

*(ЕЧИСЛО(ГПР(E2:E15;L3:U3;1;0))*1))*G2:G15).

  1. Введіть в комірку W18 наступну формулу: =СУММ(ЕЧИСЛО(ПОИСКПОЗ(A2:A15;L1:U1;0)

*ПОИСКПОЗ(C2:C15;L2:U2;0)

*ПОИСКПОЗ(E2:E15;L3:U3;0))*G2:G15) і Ви повинні отримати наступні значення і звісно потрібно задати примітку як показано на зразку зображення.

1

2

3

4

 

 

Примітка до №6 пункту завдання!

Формули масиву іноді називають формулами CSE, так як для їх введення в книгах використовується поєднання клавіш CTRL + SHIFT + ВВІД (ENTER).

Короткий вступ в масиви і формули масиву

Якщо вам доводилося хоча б трохи займатися програмуванням, ви, швидше за все, стикалися з терміном масив. Для наших цілей масив можна уявити як набір елементів. В Excel ці елементи можуть перебувати в окремому рядку (в цьому випадку мова йде про одновимірному горизонтальному масиві), в стовпці (одновимірний вертикальний масив) або в декількох рядках і шпальтах (двовимірний масив). В Excel можна створювати тривимірні масиви або формули масивів.

Формула масиву представляє собою формулу, за допомогою якої можна виконувати різні обчислення з одним або декількома елементами в масиві. Формули масиву можуть повертати як окреме значення, так і безліч значень. Наприклад, можна помістити формулу масиву в діапазон комірок і скористатися цією формулою для обчислення шпальти чи рядки проміжних підсумків. Крім того, можна помістити формулу масиву в окремій клітинці, а потім обчислити окреме значення. Формула масиву, розташована в декількох осередках, називається формулою з декількома осередками, а формула масиву, що знаходиться в одній комірці, носить назву формули з одним осередком.

Склад технологічних операцій.

  1.          На наступному Листі створіть таблицю за поданим зразком та виведіть поточні дати як показано на зразку.
  2.          Перейдіть на наступний Лис і перейменуйте його на Товарний чек і створіть таблицю за поданим зразком та в загальну суму введіть наступну формулу =СУММ(B2:B5*C2:C5) використовуючи масив.
  3.          Перейдіть на наступний Лис і перейменуйте його на Транспортування, виконайте таблицю за поданим зразком далі виділіть від А1 до В8 і натискаємо комбінацію клавіш Ctrl + Shift + Enter і Ви отримаєте такий вигляд таблиці як показано на зображенні.

 

 

Склад технологічних операцій.

  1. Перейдіть на наступний Лист і задайте йому ім’я Таблиця множення та створіть таблицю за поданим зразком. Виділіть комірки від В2 до К11 і введіть формулу =A2:A11*B1:K1 і натисніть Ctrl + Shift + Enter. Після вірно введеної формули ви отримаєте таблицю множення як показано на зразку.

 

  1. Перейдіть до наступного Листа та перейменуйте його на Вибіркове сумування та створіть таблицю за поданим зразком нижче. В комірку G4 потрібно вивести випадаючий список Замовників використовуючи таку послідовність дій Даные>Проверка данных>Тип даных>Список>Источник =$K$4:$K$12 і натиснути Enter. В комірку G5 потрібно вивести випадаючий список Товарів використовуючи таку послідовність дій Даные>Проверка данных>Тип даных>Список>Источник =$J$4:$J$6 і натиснути Enter. В комірку G6 потрібно вивести наступну формулу =СУММ((C3:C21=G4)*(B3:B21=G5)*D3:D21) і натиснути Ctrl + Shift + Enter.

Після завершення завдання збережіть роботу та покажіть майстру для отримання Оцінки.


 

Назва

Опис технологічного процесу

Малюнок

Організація робочого місця

Робоче місце добре освітлене.

Картинки по запросу робоче місце оператор пк

Вентиляція приміщення.

Відсутність зайвих предметів, матеріалів.

Інструмент, який беруть правою рукою лежить з права,

а що, лівою рукою – зліва.

Користування справним інструментом.

Оцінка якості

Системний блок оцінюється за якість виконаної роботи.

Картинки по запросу техніка безпеки в кабінеті інформатики

Всі матеріали підключені послідовно.

Немає пошкоджень.

Зайвих пристроїв та інструментів.

Чистота робочого місця та апаратури.

Техніка безпеки

Робота в спецодязі та взутті.

Монітор, системний блок, клавіатура та

маніпулятор (миша) в справному стані. Робоче місце відповідає

Вимогам охорони праці в повному обсязі.

Трудові витрати

Матеріали та їх кількість:

Картинки по запросу документи

Картинки по запросу комп'ютерний стіл креслення

Картинки по запросу microsoft office

Картинки по запросу медичний халат

15 – Інструкційно-технологічних карт;

15 – укомплектованих робочих місць;

15 – комплектів встановленого програмного забезпечення;

15 медичних халатів.

Час виконання роботи:

5 годин.

 

zip
Пов’язані теми
Інформатика, 9 клас, Розробки уроків
Інкл
До підручника
Інформатика 9 клас (Бондаренко О.О., Ластовецький В.В., Пилипчук О.П., Шестопалов Є.А.)
Додано
28 жовтня
Переглядів
60
Оцінка розробки
Відгуки відсутні
Безкоштовний сертифікат
про публікацію авторської розробки
Щоб отримати, додайте розробку

Додати розробку